use strict;
my $str = ':86:Mitsubishi Co Ltd
1-19, Higashi 88
MHCBJPJTXXX
SCN123
:61:2202280228C211619,64NMSCSWEEP A/C 555603
:86:Mitsubishi Co Ltd
MHCBJPJTXXX
MHCBJPJTXXX
MHCBJPJTXXX';
my $regex = qr/\r?\n(?!:)/mp;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";