const regex = /\r?\n(?!:)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\r?\\n(?!:)', 'gm')
const str = `:86:Mitsubishi Co Ltd
1-19, Higashi 88
MHCBJPJTXXX
SCN123
:61:2202280228C211619,64NMSCSWEEP A/C 555603
:86:Mitsubishi Co Ltd
MHCBJPJTXXX
MHCBJPJTXXX
MHCBJPJTXXX`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);