# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\r?\n(?!:)"
test_str = (":86:Mitsubishi Co Ltd\n"
"1-19, Higashi 88\n"
"MHCBJPJTXXX\n"
"SCN123\n"
":61:2202280228C211619,64NMSCSWEEP A/C 555603\n"
":86:Mitsubishi Co Ltd\n"
"MHCBJPJTXXX\n"
"MHCBJPJTXXX\n"
"MHCBJPJTXXX")
subst = " "
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.