#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.*[0-9])(?=.*[a-z])(?=.*[A-Z]).{0,}$"
Local $sString = "Pass1234" & @CRLF & _
"Pass1234" & @CRLF & _
"pass" & @CRLF & _
"PASS" & @CRLF & _
"papsssssss" & @CRLF & _
"PASS1234" & @CRLF & _
"Pass123444khgvdfvzkeavfzeZRRGGRTTRGTRGZERgzefefrfr898888zr88r88" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")