import re
regex = re.compile(r"^(?=.*[0-9])(?=.*[a-z])(?=.*[A-Z]).{0,}$", flags=re.MULTILINE)
test_str = ("Pass1234\n"
"Pass1234\n"
"pass\n"
"PASS\n"
"papsssssss\n"
"PASS1234\n"
"Pass123444khgvdfvzkeavfzeZRRGGRTTRGTRGZERgzefefrfr898888zr88r88\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")