re = /^(?=.*[0-9])(?=.*[a-z])(?=.*[A-Z]).{0,}$/m
str = 'Pass1234
Pass1234
pass
PASS
papsssssss
PASS1234
Pass123444khgvdfvzkeavfzeZRRGGRTTRGTRGZERgzefefrfr898888zr88r88
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end