use strict;
my $str = 'Pass1234
Pass1234
pass
PASS
papsssssss
PASS1234
Pass123444khgvdfvzkeavfzeZRRGGRTTRGTRGZERgzefefrfr898888zr88r88
';
my $regex = qr/^(?=.*[0-9])(?=.*[a-z])(?=.*[A-Z]).{0,}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}