$re = '/^(?=.*[0-9])(?=.*[a-z])(?=.*[A-Z]).{0,}$/m';
$str = 'Pass1234
Pass1234
pass
PASS
papsssssss
PASS1234
Pass123444khgvdfvzkeavfzeZRRGGRTTRGTRGZERgzefefrfr898888zr88r88
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);