using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:2[0-4][0-9]|25[0-5]|1?[0-9]?[0-9])[.](?:2[0-4][0-9]|25[0-5]|1?[0-9]?[0-9])[.](?:2[0-4][0-9]|25[0-5]|1?[0-9]?[0-9])[.](?:2[0-4][0-9]|25[0-5]|1?[0-9]?[0-9])$";
string input = @"0.0.0.0
192.168.1.1
127.0.0.1
255.255.255.255
9.9.9.253
1.1.1.1
256.0.0.0
0.256.0.0
0.0.256.0
0.0.0.256
.0.0.0.0
0.0.0.0.
a.a.a.a
-1.-1.-1.-1
256.256.256.256
^(\b(?:2[0-4][0-9]|25[0-5]|1?[0-9]?[0-9])\b\.\b(?:2[0-4][0-9]|25[0-5]|1?[0-9]?[0-9])\b\.\b(?:2[0-4][0-9]|25[0-5]|1?[0-9]?[0-9])\b\.\b(?:2[0-4][0-9]|25[0-5]|1?[0-9]?[0-9])\b)$
1
1.
1.1
1.1
1.1.
1.1.1
1.1.1.
1.1.1.1
1.1.1.1.
1.1.1.1.1
20
20.
20.20
20.20.
20.20.20
20.20.20.
20.20.20.20
20.20.20.20.
20.20.20.20.20
300
300.
300.300
300.300.
300.300.300
300.300.300.
300.300.300.300
300.300.300.300.
300.300.300.300.300
4000
4000.
4000.4000
4000.4000.
4000.4000.4000
4000.4000.4000.
4000.4000.4000.4000
4000.4000.4000.4000.
4000.4000.4000.4000.4000
amiraizat124@gmail.com
ak</';
1,1,1,1";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}