import Foundation
let pattern = #"^(?:2[0-4][0-9]|25[0-5]|1?[0-9]?[0-9])[.](?:2[0-4][0-9]|25[0-5]|1?[0-9]?[0-9])[.](?:2[0-4][0-9]|25[0-5]|1?[0-9]?[0-9])[.](?:2[0-4][0-9]|25[0-5]|1?[0-9]?[0-9])$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
0.0.0.0
192.168.1.1
127.0.0.1
255.255.255.255
9.9.9.253
1.1.1.1
256.0.0.0
0.256.0.0
0.0.256.0
0.0.0.256
.0.0.0.0
0.0.0.0.
a.a.a.a
-1.-1.-1.-1
256.256.256.256
^(\b(?:2[0-4][0-9]|25[0-5]|1?[0-9]?[0-9])\b\.\b(?:2[0-4][0-9]|25[0-5]|1?[0-9]?[0-9])\b\.\b(?:2[0-4][0-9]|25[0-5]|1?[0-9]?[0-9])\b\.\b(?:2[0-4][0-9]|25[0-5]|1?[0-9]?[0-9])\b)$
1
1.
1.1
1.1
1.1.
1.1.1
1.1.1.
1.1.1.1
1.1.1.1.
1.1.1.1.1
20
20.
20.20
20.20.
20.20.20
20.20.20.
20.20.20.20
20.20.20.20.
20.20.20.20.20
300
300.
300.300
300.300.
300.300.300
300.300.300.
300.300.300.300
300.300.300.300.
300.300.300.300.300
4000
4000.
4000.4000
4000.4000.
4000.4000.4000
4000.4000.4000.
4000.4000.4000.4000
4000.4000.4000.4000.
4000.4000.4000.4000.4000
amiraizat124@gmail.com
ak</';
1,1,1,1
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)