import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:2[0-4][0-9]|25[0-5]|1?[0-9]?[0-9])[.](?:2[0-4][0-9]|25[0-5]|1?[0-9]?[0-9])[.](?:2[0-4][0-9]|25[0-5]|1?[0-9]?[0-9])[.](?:2[0-4][0-9]|25[0-5]|1?[0-9]?[0-9])$";
final String string = "0.0.0.0\n"
+ "192.168.1.1\n"
+ "127.0.0.1\n"
+ "255.255.255.255\n"
+ "9.9.9.253\n"
+ "1.1.1.1\n\n\n"
+ "256.0.0.0\n"
+ "0.256.0.0\n"
+ "0.0.256.0\n"
+ "0.0.0.256\n"
+ ".0.0.0.0\n"
+ "0.0.0.0.\n"
+ "a.a.a.a\n"
+ "-1.-1.-1.-1\n"
+ "256.256.256.256\n"
+ "^(\\b(?:2[0-4][0-9]|25[0-5]|1?[0-9]?[0-9])\\b\\.\\b(?:2[0-4][0-9]|25[0-5]|1?[0-9]?[0-9])\\b\\.\\b(?:2[0-4][0-9]|25[0-5]|1?[0-9]?[0-9])\\b\\.\\b(?:2[0-4][0-9]|25[0-5]|1?[0-9]?[0-9])\\b)$\n\n"
+ "1\n"
+ "1.\n"
+ "1.1\n"
+ "1.1\n"
+ "1.1.\n"
+ "1.1.1\n"
+ "1.1.1.\n"
+ "1.1.1.1\n"
+ "1.1.1.1.\n"
+ "1.1.1.1.1\n"
+ "20\n"
+ "20.\n"
+ "20.20\n"
+ "20.20.\n"
+ "20.20.20\n"
+ "20.20.20.\n"
+ "20.20.20.20\n"
+ "20.20.20.20.\n"
+ "20.20.20.20.20\n"
+ "300\n"
+ "300.\n"
+ "300.300\n"
+ "300.300.\n"
+ "300.300.300\n"
+ "300.300.300.\n"
+ "300.300.300.300\n"
+ "300.300.300.300.\n"
+ "300.300.300.300.300\n"
+ "4000\n"
+ "4000.\n"
+ "4000.4000\n"
+ "4000.4000.\n"
+ "4000.4000.4000\n"
+ "4000.4000.4000.\n"
+ "4000.4000.4000.4000\n"
+ "4000.4000.4000.4000.\n"
+ "4000.4000.4000.4000.4000\n"
+ "amiraizat124@gmail.com\n"
+ "ak</';\n"
+ "1,1,1,1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}