// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:2[0-4][0-9]|25[0-5]|1?[0-9]?[0-9])[.](?:2[0-4][0-9]|25[0-5]|1?[0-9]?[0-9])[.](?:2[0-4][0-9]|25[0-5]|1?[0-9]?[0-9])[.](?:2[0-4][0-9]|25[0-5]|1?[0-9]?[0-9])$").unwrap();
let string = "0.0.0.0
192.168.1.1
127.0.0.1
255.255.255.255
9.9.9.253
1.1.1.1
256.0.0.0
0.256.0.0
0.0.256.0
0.0.0.256
.0.0.0.0
0.0.0.0.
a.a.a.a
-1.-1.-1.-1
256.256.256.256
^(\\b(?:2[0-4][0-9]|25[0-5]|1?[0-9]?[0-9])\\b\\.\\b(?:2[0-4][0-9]|25[0-5]|1?[0-9]?[0-9])\\b\\.\\b(?:2[0-4][0-9]|25[0-5]|1?[0-9]?[0-9])\\b\\.\\b(?:2[0-4][0-9]|25[0-5]|1?[0-9]?[0-9])\\b)$
1
1.
1.1
1.1
1.1.
1.1.1
1.1.1.
1.1.1.1
1.1.1.1.
1.1.1.1.1
20
20.
20.20
20.20.
20.20.20
20.20.20.
20.20.20.20
20.20.20.20.
20.20.20.20.20
300
300.
300.300
300.300.
300.300.300
300.300.300.
300.300.300.300
300.300.300.300.
300.300.300.300.300
4000
4000.
4000.4000
4000.4000.
4000.4000.4000
4000.4000.4000.
4000.4000.4000.4000
4000.4000.4000.4000.
4000.4000.4000.4000.4000
amiraizat124@gmail.com
ak</';
1,1,1,1";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}