package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([\w]{1,127}\/[\w]{1,127})(?:;\s+charset=([\w!#$%^&-~{}]{1,127}))?(?:;\s+boundary=([\w!#$%^&-~{}]{1,70}))?$`)
var str = `application/json
application/json; charset=a!$^&#-~{\`}
application/json; charset=a!$^&#-~{\`}; boundary=aa
application/json; boundary=aa`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}