$re = '/^([\w]{1,127}\/[\w]{1,127})(?:;\s+charset=([\w!#$%^&-~{}]{1,127}))?(?:;\s+boundary=([\w!#$%^&-~{}]{1,70}))?$/m';
$str = 'application/json
application/json; charset=a!$^&#-~{`}
application/json; charset=a!$^&#-~{`}; boundary=aa
application/json; boundary=aa';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);