import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([\\w]{1,127}\\/[\\w]{1,127})(?:;\\s+charset=([\\w!#$%^&-~\\{\\}]{1,127}))?(?:;\\s+boundary=([\\w!#$%^&-~\\{\\}]{1,70}))?$";
final String string = "application/json\n"
+ "application/json; charset=a!$^&#-~{`}\n"
+ "application/json; charset=a!$^&#-~{`}; boundary=aa\n"
+ "application/json; boundary=aa";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}