const regex = /^([\w]{1,127}\/[\w]{1,127})(?:;\s+charset=([\w!#$%^&-~{}]{1,127}))?(?:;\s+boundary=([\w!#$%^&-~{}]{1,70}))?$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([\\w]{1,127}\\\/[\\w]{1,127})(?:;\\s+charset=([\\w!#$%^&-~{}]{1,127}))?(?:;\\s+boundary=([\\w!#$%^&-~{}]{1,70}))?$', 'mg')
const str = `application/json
application/json; charset=a!\$^&#-~{\`}
application/json; charset=a!\$^&#-~{\`}; boundary=aa
application/json; boundary=aa`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}