// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([\w]{1,127}\/[\w]{1,127})(?:;\s+charset=([\w!#$%^&-~{}]{1,127}))?(?:;\s+boundary=([\w!#$%^&-~{}]{1,70}))?$").unwrap();
let string = "application/json
application/json; charset=a!$^&#-~{`}
application/json; charset=a!$^&#-~{`}; boundary=aa
application/json; boundary=aa";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}