import Foundation
let pattern = ##"^([\w]{1,127}\/[\w]{1,127})(?:;\s+charset=([\w!#$%^&-~{}]{1,127}))?(?:;\s+boundary=([\w!#$%^&-~{}]{1,70}))?$"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
application/json
application/json; charset=a!$^&#-~{`}
application/json; charset=a!$^&#-~{`}; boundary=aa
application/json; boundary=aa
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)