const regex = /(\/Network\/Cambric Corporate Center\/).{8}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\\/Network\\\/Cambric Corporate Center\\\/).{8}', 'gm')
const str = `/Network/Cambric Corporate Center/1164.DEV1164`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);