re = /(\/Network\/Cambric Corporate Center\/).{8}/m
str = '/Network/Cambric Corporate Center/1164.DEV1164'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result