$re = '/(\/Network\/Cambric Corporate Center\/).{8}/m';
$str = '/Network/Cambric Corporate Center/1164.DEV1164';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;