// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\/Network\/Cambric Corporate Center\/).{8}").unwrap();
let string = "/Network/Cambric Corporate Center/1164.DEV1164";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}