#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)<img src=".*?((/img/[^"]+)/thumbs/([^"]+))".*alt="(.*?)"[^>]*class="([^"]*popup-img[^"]*)"[^>]*>"
Local $sString = "<img src="http://example/img/product/name/thumbs/100/img1.jpg" alt="описание фото1" width="100" height="100" caption="false" class="popup-img" />" & @CRLF & _
"" & @CRLF & _
"<img src="http://example/img/product/name/thumbs/100/img2.jpg" alt="описание фото2" width="100" height="100" caption="false" class="popup-img left" />" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"<img src="http://example/img/product/name/thumbs/100/img2.jpg" alt="описание фото2" width="100" height="100" caption="false" class="wrong-class left" />"
Local $sSubst = "<a class="$5" href="..$2/$3" title="$4" style="background: url('..$1');-webkit-background-size: cover;background-size: cover;"></a>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)