import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<img src=\".*?((/img/[^\"]+)/thumbs/([^\"]+))\".*alt=\"(.*?)\"[^>]*class=\"([^\"]*popup-img[^\"]*)\"[^>]*>";
final String string = "<img src=\"http://example/img/product/name/thumbs/100/img1.jpg\" alt=\"описание фото1\" width=\"100\" height=\"100\" caption=\"false\" class=\"popup-img\" />\n\n"
+ "<img src=\"http://example/img/product/name/thumbs/100/img2.jpg\" alt=\"описание фото2\" width=\"100\" height=\"100\" caption=\"false\" class=\"popup-img left\" />\n\n\n"
+ "<img src=\"http://example/img/product/name/thumbs/100/img2.jpg\" alt=\"описание фото2\" width=\"100\" height=\"100\" caption=\"false\" class=\"wrong-class left\" />";
final String subst = "<a class=\"$5\" href=\"..$2/$3\" title=\"$4\" style=\"background: url('..$1');-webkit-background-size: cover;background-size: cover;\"></a>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}