$re = '~<img src=".*?((/img/[^"]+)/thumbs/([^"]+))".*alt="(.*?)"[^>]*class="([^"]*popup-img[^"]*)"[^>]*>~mi';
$str = '<img src="http://example/img/product/name/thumbs/100/img1.jpg" alt="описание фото1" width="100" height="100" caption="false" class="popup-img" />
<img src="http://example/img/product/name/thumbs/100/img2.jpg" alt="описание фото2" width="100" height="100" caption="false" class="popup-img left" />
<img src="http://example/img/product/name/thumbs/100/img2.jpg" alt="описание фото2" width="100" height="100" caption="false" class="wrong-class left" />';
$subst = "<a class=\"$5\" href=\"..$2/$3\" title=\"$4\" style=\"background: url('..$1');-webkit-background-size: cover;background-size: cover;\"></a>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;