// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?mi)<img src=".*?((/img/[^"]+)/thumbs/([^"]+))".*alt="(.*?)"[^>]*class="([^"]*popup-img[^"]*)"[^>]*>"#).unwrap();
let string = "<img src=\"http://example/img/product/name/thumbs/100/img1.jpg\" alt=\"описание фото1\" width=\"100\" height=\"100\" caption=\"false\" class=\"popup-img\" />
<img src=\"http://example/img/product/name/thumbs/100/img2.jpg\" alt=\"описание фото2\" width=\"100\" height=\"100\" caption=\"false\" class=\"popup-img left\" />
<img src=\"http://example/img/product/name/thumbs/100/img2.jpg\" alt=\"описание фото2\" width=\"100\" height=\"100\" caption=\"false\" class=\"wrong-class left\" />";
let substitution = "<a class=\"$5\" href=\"..$2/$3\" title=\"$4\" style=\"background: url('..$1');-webkit-background-size: cover;background-size: cover;\"></a>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}