import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((\\[.*\\])?(('(?:[^']|'')*'!)|([a-zA-Z0-9_]+!)))?((\\$?[a-z]{1,3}\\$?[0-9]{1,7})(\\:\\$?[a-z]{1,3}\\$?[0-9]{1,7})?|\\$?[a-z]{1,3}\\:\\$?[a-z]{1,3}|\\$?[0-9]{1,7}\\:\\$?[0-9]{1,7})";
final String string = "A1:B1\n"
+ "A$1:B$12\n"
+ "$A1:$b12\n"
+ "AA11:$BB$11\n\n"
+ "$A:B\n"
+ "A:$C\n"
+ "12:34\n"
+ "$12:$35\n\n"
+ "'hello'+[ths]ToDoList_1!D26+'Blank ''A1''(2)'!G14\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}