package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\P{L}*\p{Script=Cyrl}`)
var str = `lalala Ф
1123 Щ
1-1+2.3!! Щ
1s-1+2.3!! Щ`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}