const regex = /^\P{L}*\p{Script=Cyrl}/gmu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\P{L}*\\p{Script=Cyrl}', 'gmu')
const str = `lalala Ф
1123 Щ
1-1+2.3!! Щ
1s-1+2.3!! Щ`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}