$re = '/^\P{L}*\p{Script=Cyrl}/mu';
$str = 'lalala Ф
1123 Щ
1-1+2.3!! Щ
1s-1+2.3!! Щ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);