import re
regex = re.compile(r"^\P{L}*\p{Script=Cyrl}", flags=re.MULTILINE | re.UNICODE)
test_str = ("lalala Ф\n"
"1123 Щ\n"
"1-1+2.3!! Щ\n"
"1s-1+2.3!! Щ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")