const regex = new RegExp('Arvada( [a-zA-Z]+){0,4}[,\\.] [A-Z]{2}', 'g')
const str = `City of Arvada\\n\\nRevenue Division\\nArvada, CO 80001\\n other random words`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}