re = /Arvada( [a-zA-Z]+){0,4}[,\.] [A-Z]{2}/
str = 'City of Arvada\\n\\nRevenue Division\\nArvada, CO 80001\\n other random words'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end