$re = '/Arvada( [a-zA-Z]+){0,4}[,\.] [A-Z]{2}/';
$str = 'City of Arvada\\n\\nRevenue Division\\nArvada, CO 80001\\n other random words';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);