// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"Arvada( [a-zA-Z]+){0,4}[,\.] [A-Z]{2}").unwrap();
let string = "City of Arvada\\n\\nRevenue Division\\nArvada, CO 80001\\n other random words";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}