#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = ":.*?(?=[^a-zA-Z]+)"
Local $sString = "u:sdneUSER|r:endsUser(&g:againuser)"
Local $sSubst = ":root"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)