using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @":.*?(?=[^a-zA-Z]+)";
string substitution = @":root";
string input = @"u:sdneUSER|r:endsUser(&g:againuser)";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}