import Foundation
let pattern = #":.*?(?=[^a-zA-Z]+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"u:sdneUSER|r:endsUser(&g:againuser)"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #":root"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)