re = /:.*?(?=[^a-zA-Z]+)/
str = 'u:sdneUSER|r:endsUser(&g:againuser)'
subst = ':root'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result