$re = '/:.*?(?=[^a-zA-Z]+)/';
$str = 'u:sdneUSER|r:endsUser(&g:againuser)';
$subst = ":root";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;