use strict;
my $str = 'u:sdneUSER|r:endsUser(&g:againuser)';
my $regex = qr/:.*?(?=[^a-zA-Z]+)/p;
my $subst = ':root';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";