package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([^ ]+)\s([^ ]+)\s([^ ]+)$`)
var str = `XXX lorem ipsum1..
YYY lorem ipsum2..
ZZZ lorem ipsum3..`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}