use strict;
my $str = 'XXX lorem ipsum1..
YYY lorem ipsum2..
ZZZ lorem ipsum3..';
my $regex = qr/^([^ ]+)\s([^ ]+)\s([^ ]+)$/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";