re = /^([^ ]+)\s([^ ]+)\s([^ ]+)$/m
str = 'XXX lorem ipsum1..
YYY lorem ipsum2..
ZZZ lorem ipsum3..'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result