import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([^ ]+)\\s([^ ]+)\\s([^ ]+)$";
final String string = "XXX lorem ipsum1..\n"
+ "YYY lorem ipsum2..\n"
+ "ZZZ lorem ipsum3..";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}