import Foundation
let pattern = #"^([^ ]+)\s([^ ]+)\s([^ ]+)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
XXX lorem ipsum1..
YYY lorem ipsum2..
ZZZ lorem ipsum3..
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)