using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?mixs)1-ASCII:(?#Literales ASCII)\n
1\.1-Los\ 95\ caracteres\ ASCII\ imprimibles:\n
\ ! \"" \# \$ % & ' \( \) \* \+ , - \. /\n
0123456789 :;<=> \? @\n
ABCDEFGHIJKLMNOPQRSTUVWXYZ \[ \\ ] \^ _ `\n
abcdefghijklmnopqrstuvwxyz { \| }~ \~ \n
1\.2-Algunos\ ASCII\ extendidos: áÁàÀäÄâÂéíóú\nñÑ\tÿ\
2-Algunos\ Unicode\ no\ no\ ASCII:∫∬∭∰\u2230";
string input = @"1-ASCII:
1.1-Los 95 caracteres ASCII imprimibles:
!""#$%&'()*+,-./
0123456789:;<=>?@
ABCDEFGHIJKLMNOPQRSTUVWXYZ[\]^_`
abcdefghijklmnopqrstuvwxyz{|}~~
1.2-Algunos ASCII extendidos:áÁàÀäÄâÂéíóú
ñÑ ÿ
2-Algunos Unicode no no ASCII:∫∬∭∰∰";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}