import Foundation
let pattern = ##"""
(?mixs)1-ASCII:(?#Literales ASCII)\n
1\.1-Los\ 95\ caracteres\ ASCII\ imprimibles:\n
\ ! \" \# \$ % & ' \( \) \* \+ , - \. /\n
0123456789 :;<=> \? @\n
ABCDEFGHIJKLMNOPQRSTUVWXYZ \[ \\ ] \^ _ `\n
abcdefghijklmnopqrstuvwxyz { \| }~ \~ \n
1\.2-Algunos\ ASCII\ extendidos: áÁàÀäÄâÂéíóú\nñÑ\tÿ\
2-Algunos\ Unicode\ no\ no\ ASCII:∫∬∭∰\u2230
"""##
let regex = try! NSRegularExpression(pattern: pattern, options: .allowCommentsAndWhitespace)
let testString = ##"""
1-ASCII:
1.1-Los 95 caracteres ASCII imprimibles:
!"#$%&'()*+,-./
0123456789:;<=>?@
ABCDEFGHIJKLMNOPQRSTUVWXYZ[\]^_`
abcdefghijklmnopqrstuvwxyz{|}~~
1.2-Algunos ASCII extendidos:áÁàÀäÄâÂéíóú
ñÑ ÿ
2-Algunos Unicode no no ASCII:∫∬∭∰∰
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)