import re
regex = re.compile(r"""
(?mixs)1-ASCII:(?#Literales ASCII)\n
1\.1-Los\ 95\ caracteres\ ASCII\ imprimibles:\n
\ ! \" \# \$ % & ' \( \) \* \+ , - \. /\n
0123456789 :;<=> \? @\n
ABCDEFGHIJKLMNOPQRSTUVWXYZ \[ \\ ] \^ _ `\n
abcdefghijklmnopqrstuvwxyz { \| }~ \~ \n
1\.2-Algunos\ ASCII\ extendidos: áÁàÀäÄâÂéíóú\nñÑ\tÿ\
2-Algunos\ Unicode\ no\ no\ ASCII:∫∬∭∰\u2230
""", flags=re.VERBOSE)
test_str = ("1-ASCII:\n"
"1.1-Los 95 caracteres ASCII imprimibles:\n"
" !\"#$%&'()*+,-./\n"
"0123456789:;<=>?@\n"
"ABCDEFGHIJKLMNOPQRSTUVWXYZ[\\]^_`\n"
"abcdefghijklmnopqrstuvwxyz{|}~~\n"
"1.2-Algunos ASCII extendidos:áÁàÀäÄâÂéíóú\n"
"ñÑ ÿ\n"
"2-Algunos Unicode no no ASCII:∫∬∭∰∰")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")