import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?mixs)1-ASCII:(?#Literales ASCII)\\n\n"
+ "1\\.1-Los\\ 95\\ caracteres\\ ASCII\\ imprimibles:\\n\n"
+ "\\ ! \\\" \\# \\$ % & ' \\( \\) \\* \\+ , - \\. /\\n\n"
+ "0123456789 :;<=> \\? @\\n\n"
+ "ABCDEFGHIJKLMNOPQRSTUVWXYZ \\[ \\\\ ] \\^ _ `\\n\n"
+ "abcdefghijklmnopqrstuvwxyz \\{ \\| \\}~ \\~ \\n\n"
+ "1\\.2-Algunos\\ ASCII\\ extendidos: áÁàÀäÄâÂéíóú\\nñÑ\\tÿ\\\n"
+ "2-Algunos\\ Unicode\\ no\\ no\\ ASCII:∫∬∭∰\\u2230";
final String string = "1-ASCII:\n"
+ "1.1-Los 95 caracteres ASCII imprimibles:\n"
+ " !\"#$%&'()*+,-./\n"
+ "0123456789:;<=>?@\n"
+ "ABCDEFGHIJKLMNOPQRSTUVWXYZ[\\]^_`\n"
+ "abcdefghijklmnopqrstuvwxyz{|}~~\n"
+ "1.2-Algunos ASCII extendidos:áÁàÀäÄâÂéíóú\n"
+ "ñÑ ÿ\n"
+ "2-Algunos Unicode no no ASCII:∫∬∭∰∰";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}